コンテンツへスキップ

HD4200 + HD6450 Surround View環境構築

メインPCはFull-HD * 2のデュアルディスプレイ環境なのですが、近々トリプルにしようと考えています。
というのも2画面はポートレートで、残る一つはランドスケープというのが作業上効率がいい気がします。
コーディングや、Webページ、PDF等ドキュメントは縦に長い方が便利。

今はオンボードVGAの「HD4200」を使用しており、これだけだと2画面しか同時出力できません。
なので、別途HD6000系のローエンド「HD6450」を導入することにしました。
ゲームをする訳でもないので、ファンレス・低消費電力の方が重要です。
今回は以下の「SAPPHIRE HD6450」を購入。3,470円。安い。

一枚で3画面同時出力できるものもあるのですが、今回はコスト優先のためSurround View機能を利用して同時使用するということです。

とりあえず、環境は以下の通り。

  • OS: Windows 7 Professional SP1 x64
  • M/B: M3A785GXH/128M
  • Onboard VGA: HD4200
  • PCI-Express VGA: SAPPHIRE HD6450(11190-02-20G)

ドライバのダウンロードなどはご利用の環境に合ったものをお探しください。

[1] BIOS設定

まず、グラフィックボードを取り付けたあとに、両方のVGAを有効にするために「Surround View」を有効にします。
M3A785GXH/128Mだと、
[Advanced] - [Chipset Setting] - [Surround View] => [Enabled]
このマザーボードでは[Share Memory]を[Auto]に設定すると、Surround Viewが無効化されてしまう仕様なので注意しましょう。

[1.5] インストールパッケージの選択

ここが最大の問題です。

HD4000シリーズは既にLegacy扱いなので、HD6450との間で不具合が発生するようです。
現在最新の13.9及び13.9 Legacy(のDisplay Driver)をインストールすると、

Catalyst Control Center: Host application は動作を停止しました

Catalyst Control Center(以下CCC)は死亡。
dxdiagを実行すると同じく動作が停止し、

DxDiag は前回このプログラムが使用されたときに Direct3Dへのアクセスに問題があったことを検出しました。今回、Direct3Dの使用を回避しますか?

というように、Direct3Dに問題が発生しているようです。
それだけでなく、MPC-HCなど一部ビデオ関係のソフトウェアも動作しなくなってしまいました。参った。

なので様々な組み合わせでインストール・アンストールを繰り返して検証してみた結果…

  1. HD4200, HD6450両方が対応しているCatalyst 12.4 をインストール。
  2. HD4200はCatalyst 13.9 Legacy、HD6450には13.1(のDisplay Driver)をインストール。

という結論に達しました。(1)が最も楽です。
なるべく最新のドライバを適用しようとすると(2)になります。

[2] ダウンロード

まず、必要なパッケージをダウンロードしておきましょう。
最近AMDのサイトが改悪リニューアルされてから、サイトに様々な不具合があるのでご注意を。
過去のCatalystは、「AMD Graphics Drivers and Software」の右側から各OSのリンクへ飛び、
amd_download_os
右側の[Helpful Links] - [Previous Drivers and Software] のページでダウンロードできます。
amd_download_helpful

この64bitページにも不具合があり、「12.2」「12.4」のページコンテンツが空っぽになってしまっています。
32bitのページではリンクすらされていないというひどい有様。
(11/16 確認したところ、修正されたようです)


(1)の方は、Catalyst 12.4を以下より。なんかリフェラ制限でダウンロードできない時は下のサイトで。

http://www2.ati.com/drivers/12-4_vista_win7_64_dd_ccc.exe
(予備)http://www.techpowerup.com/downloads/2132/amd-catalyst-12-4-software-suite-vista-7-64-bit/

(2)の方は、13.9 Legacy と 13.1 のページよりダウンロードします。一応、直リンは以下より。

http://www2.ati.com/drivers/legacy/13-9-legacy_vista_win7_64_dd_ccc_whql.exe
http://www2.ati.com/drivers/13-1_vista_win7_win8_64_dd_ccc_whql.exe

[3] インストール

既にドライバがインストールされてるかと思いますが、一旦削除します。
コントロールパネルから、[AMD Catalyst Install Manager]で「全てのAMDソフトウェアの高速アンインストール」
catalyst_uninstall

また、念のため「AMD Catalyst Un-install Utility」を用いてクリーンアップしときます。(Windows 7のみ対応)
そしたら再起動します。

そしたら早速インストールにとりかかります。

(1)の方は、そのままインストーラを実行して、サクサク進めれば大丈夫です。
再起動後、オンボードVGAからの出力が無い場合、デバイスマネージャをみると、HD4200が「動作を停止しました」とかなっているので、手動でインストールします。

[ドライバーの更新] - [コンピュータを参照してドライバーソフトウェアを検索します] -
(デフォルト)「C:\AMD\Support\12-4_vista_win7_64_dd_ccc\Packages\Drivers\Display」
[サブフォルダーを検索する]をチェック

とかにして[次へ]でたぶんいけます。


(2)の方は、まずCatalyst 13.9 Legacyの方を普通にインストールします。
この時点で、たぶんオンボードVGAは停止しています。
したら、13.1の展開だけします。(インストーラ起動直後のInstallを実行後、Install Managerが起動したらキャンセル)
後は、デバイスマネージャから、HD6450のドライバをインストールします。

[ドライバーの更新] - [コンピュータを参照してドライバーソフトウェアを検索します] -
(デフォルト)「C:\AMD\Support\13-1_vista_win7_win8_64_dd_ccc_whql\Packages\Drivers\Display」
[サブフォルダーを検索する]をチェック

とかにして[次へ]でインストールし、たぶんHD6450は動きます。(ドライバのバージョンは「9.12.0.0」)
まだオンボードVGAは停止してるはずなので、一度デバイスマネージャからHD4200を[削除]します。
デバイスマネージャのメニューバーの[操作]-[ハードウェア変更のスキャン]を実行します。
すると、HD4200のドライバ自動インストールが始まり、終わるとオンボードVGAが動くと思います。
ドライババージョンを確認して「8.970.100.1100」となっていなければ、先程と同じ要領で13.9 LegacyのDisplay Driverに更新します。
んで、再起動。

[4] 確認

再起動してみて、両方からの出力が確認できればOKです。
念のためCCCを起動したり、dxdiagなどで確認してみてください。ビデオ再生しながら、ディスプレイ間移動とか。
Catalyst_12.4_HD4200_6450

Catalyst_13.9L_13.1_HD4200_6450


今はこんな感じで動いてますが、他にもっといい方法があれば教えてください。


コメントを残す

メールアドレスが公開されることはありません。