コンテンツへスキップ

忘れないうちに書かないと…

さてと、新しいサーバー機はOptiPlex 755とかいうDellの法人向けのスモールフォームファクタ(SF)型。
もちろん中古で。3,500円程度だったので購入。

[ハードウェア構成]

CPU : Celeron 430 1.8GHz (L2 : 512KB / FSB : 800MHz)
Chipset : Intel Q35(ICH9DO)
Memory : DDR2-SDRAM (667 / 800MHz) 512MB から 1.5GBへ増設 ⇒ 3.5GBへ増設
HDD 80GB から SSD 32GB (SP032GBSS2T10S25)へ置換
NIC : Intel 82566DM Gigabit Ethernet LAN

ハードウェア構成をみても、なかなかいい感じ。
というか、ジャンク・オンボロだらけの私のPCの中ではなかなか高級な部類だぞ(苦笑)

下にBefore / Afterの写真がありますが、世代が変わり過ぎでヤバいです。
以前コンデンサ交換かなんかで取り上げましたが(該当記事)、Compaq Evo Desktop D510 SFとかいう、それこそ十年物の化石PCです。
まあ消費電力も大きいし、無理やり二台突っ込んでRAID組んでるHDDどもの寿命も心配だし、うるさいし。
HDD温度がかなり高いので、猛暑になりポックリ逝くのでは・・・ということで思い立ったわけです。

サーバー機

新しくするからには、いろいろ問題が多いHDDをやめて、SSDに。
最も少ない投資で、多くの利益が得られると思います。
まあ、個人的なサーバー用途ですのでコスト重視で以下の製品に。32GBで十分だし。

あ、それと一つ躓いたこと。
メモリが購入時512MBしかない(CentOSをGUIインストールできない)ので、メモリは当然増設。
DDR2なメモリなのでいくらか転がってるはず。
で、 運よくDDR2-533(PC2-4200) 1GB*4を発掘したわけだが・・・問題発生。
もう一度、先述したハードウェア構成を見てみると、
チップセットの制限だったか覚えていないが、対応メモリは「DDR2-SDRAM (667 / 800MHz)」 とある。
533MHz は動作しないのだ。

  • メモリに対して言えば、上位互換性がある
    (例:DDR2-800がDDR2-533と動作し得る)
  • マザーボード(チップセット?)側は必ずしも上位互換ではない
    (例:DDR2-800対応でもDDR2-533が動作可能でない)

そんなこんなで結局見つかったのはDDR2-667 1GB一本だけ。
結果、1.5GBに。まあ、足りるよね。

さて、引っ越し作業。
旧鯖機HDDからコピーして引っ越そうかと思ったが、RAID組んであるし、小さいストレージへの移行は面倒なので、再構築しました。
流石SSD。読み書き早くて静かで低発熱でサイコーです。
もっと早くヤるんだった
大きなトラブルもなく移行できたので満足です。
Celeron 430ですが特に遅いとも感じないし、低発熱で良い石ですね。
力不足を感じたら、Pentium Dual-CoreやCore2 Duoあたりに置換すればよろし。
暫くはこれで運用して参ります。

[ 追記 ]
先日、秋葉原を徘徊した時にじゃんぱらにてDDR2-800 1GBなメモリを2枚買ってきました。
メジャーチップ扱いではなく、1枚780円ぐらいでしたが。
KEIANと書かれたラベルが貼ってあり、製品ページをみると、DRAMはELPIDA製チップらしい。
メジャーチップ扱いのものより安く買えてちょっとラッキー?

ジャンク品は目ぼしいものがありませんでした・・・
あ、でも299円で買ったPS/2キーボード がそこそこ良さそうだったので確保。(もちろん日本語109)
ELECOMやらBUFFALOで500円前後で売られていますが、キータッチはこっちの方が優っています。
ACPIホットキーは付いていませんが、あんなのあるだけ邪魔だし。

一昨日16日に、本サイトを動かしているサーバー機を更新しました。
これに関しては、また後ほど詳しく書こうと思います。

また、16日~17日にかけて、サーバーの設定ミスによりアクセス不能となっておりました。
 わざわざ零細サイトにアクセスしようとしてくださった方、申し訳ありませんでした。
一応確認したつもりだったんですが・・・
いち早く異常を報告してくれたGoogleウェブマスターツールに感謝です。

やっぱりPHPを5.3.11へダウングレードした。
昨日だか一昨日だかにPHP 5.4.1, 5.3.11がリリースされたみたいなのでついでというか。
バグフィックスが主みたいですけどね。

まぁPukiWikiの件もありますし、しばらくはこれでいきましょう。
ただ、別のWikiないし汎用CMSに乗り換えようかとも考えています。

[追記]
できました ⇒ PHP5.4系にアップデート

こんばんは。またも久々の投稿となりました。
先週末よりウイルス性胃腸炎だか(ノロか?)にかかって、 なんかもう・・・疲れました。

で、今日はサーバーを色々といじったのでメモ。

まずはApacheとPHPのアップデート。
 セキュリティフィックスを含むので脆弱性を突いた攻撃を受けないように最新版にしないとね。
しかし、PHP 5.3.x系から5.4.xにアップデートした関係でPukiwikiの動作に影響が出てしまいました。

PukiWiki-dev:BugTrack2/349「php-5.4.0で動作させる対応」

Pukiwiki開発向けWikiにて色々報告されてますね。
私のところでも500エラーを吐いていましたが、とりあえずlib/func.phpの修正をしたら一応出力されるようになりました。
ただ、一部MenuBarが出力されない。原因調べは時間のある時に。
早いうちに公式対応してくれるのを望むが…時間かかりそうだよな。(ほぼ開発停止なので)

お次はサーバーの移動。
といっても自宅サーバー機の物理的な位置移動のこと(笑)
最近HDDが共振してうなり音が顕著になってきたので、押入れにぶち込んだ。
これでかなり自室は静かになりました。
夏はどうなるか知らないけどね←

あと、部屋を整理してたらDDR-SDRAM 1GBなメモリを発掘したので早速増設。
512MB+512MBから1GB+512MBで、50%増量ですな。
時々スワップが発生していたので多少改善されそうかな。
流石にオンボロモいいとこなので自鯖新調計画を近々。

あとはApache周りのチューニングしたりログ整理した。

今日はここまで。

[追記]
PukiWikiの問題、PHPアップデート成功です ⇒ PHP5.4系にアップデート